summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md10
-rwxr-xr-xsetup.py7
2 files changed, 7 insertions, 10 deletions
diff --git a/README.md b/README.md
index e5595f9..58bb654 100644
--- a/README.md
+++ b/README.md
@@ -1,8 +1,4 @@
-`ipaddr.py` is a library for working with IP addresses, both IPv4 and IPv6.
-It was developed by Google for internal use, and is now open source.
+ipaddr.py is a library for working with IP addresses, both IPv4 and IPv6.
-Project home page: https://github.com/google/ipaddr-py
-
-Please send contributions to ipaddr-py-dev@googlegroups.com. Code should
-include unit tests and follow the Google Python style guide:
-https://google.github.io/styleguide/pyguide.html
+It has been superseded by ipaddress from the Python 3 standard library, and its
+Python 2 backport.
diff --git a/setup.py b/setup.py
index 888f8f4..24ef4cf 100755
--- a/setup.py
+++ b/setup.py
@@ -18,15 +18,16 @@ from distutils.core import setup
import ipaddr
-
setup(name='ipaddr',
+ description="Google's IP address manipulation library",
+ long_description=open('README.md').read(),
maintainer='Google',
maintainer_email='ipaddr-py-dev@googlegroups.com',
version=ipaddr.__version__,
- url='http://code.google.com/p/ipaddr-py/',
+ url='https://github.com/google/ipaddr-py',
license='Apache License, Version 2.0',
classifiers=[
- 'Development Status :: 5 - Production/Stable',
+ 'Development Status :: 6 - Mature',
'Intended Audience :: Developers',
'License :: OSI Approved :: Apache Software License',
'Operating System :: OS Independent',