summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikel Ward <mbw@google.com>2017-09-14 17:42:10 -0700
committerMikel Ward <mbw@google.com>2017-09-15 11:32:08 -0700
commit05b7eb002725faf2abfa3fe411df40c32b3e5d0e (patch)
tree47fa1ded2798e2f16feba9ad65e6534c6fe78687
parent134e5664df17a4e362ba1a4050f3b7c268a9d68a (diff)
downloadipaddr-py-05b7eb002725faf2abfa3fe411df40c32b3e5d0e.tar.gz
Update README.md and long description to say ipaddr is replaced by ipaddress.
long_description is now read straight from README.md. Note this implies both need to be plain text, since long_description is reStructuredText but README.md is Markdown. Despite this caveat, this seems to be the current convention. Also update the URL to say github is upstream rather than code.google.com.
-rw-r--r--README.md10
-rwxr-xr-xsetup.py7
2 files changed, 7 insertions, 10 deletions
diff --git a/README.md b/README.md
index e5595f9..58bb654 100644
--- a/README.md
+++ b/README.md
@@ -1,8 +1,4 @@
-`ipaddr.py` is a library for working with IP addresses, both IPv4 and IPv6.
-It was developed by Google for internal use, and is now open source.
+ipaddr.py is a library for working with IP addresses, both IPv4 and IPv6.
-Project home page: https://github.com/google/ipaddr-py
-
-Please send contributions to ipaddr-py-dev@googlegroups.com. Code should
-include unit tests and follow the Google Python style guide:
-https://google.github.io/styleguide/pyguide.html
+It has been superseded by ipaddress from the Python 3 standard library, and its
+Python 2 backport.
diff --git a/setup.py b/setup.py
index 888f8f4..24ef4cf 100755
--- a/setup.py
+++ b/setup.py
@@ -18,15 +18,16 @@ from distutils.core import setup
import ipaddr
-
setup(name='ipaddr',
+ description="Google's IP address manipulation library",
+ long_description=open('README.md').read(),
maintainer='Google',
maintainer_email='ipaddr-py-dev@googlegroups.com',
version=ipaddr.__version__,
- url='http://code.google.com/p/ipaddr-py/',
+ url='https://github.com/google/ipaddr-py',
license='Apache License, Version 2.0',
classifiers=[
- 'Development Status :: 5 - Production/Stable',
+ 'Development Status :: 6 - Mature',
'Intended Audience :: Developers',
'License :: OSI Approved :: Apache Software License',
'Operating System :: OS Independent',