summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 518d77b2b2f..affeca8c611 100644
--- a/meson.build
+++ b/meson.build
@@ -320,7 +320,9 @@ with_platform_windows = _platforms.contains('windows')
with_glx = get_option('glx')
if with_glx == 'auto'
- if with_platform_android
+ if not with_opengl
+ with_glx = 'disabled'
+ elif with_platform_android
with_glx = 'disabled'
elif with_dri
with_glx = 'dri'
@@ -345,6 +347,10 @@ if with_glx == 'dri'
endif
endif
+if not with_opengl and with_glx != 'disabled'
+ error('Building GLX without OpenGL is not supported.') \
+endif
+
if not (with_dri or with_gallium or with_glx != 'disabled')
with_gles1 = false
with_gles2 = false