summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@igalia.com>2023-02-15 19:18:27 +0000
committerMarge Bot <emma+marge@anholt.net>2023-02-17 23:53:30 +0000
commit89553408398766ef3afe949aead6e1c9b1e43961 (patch)
tree19c632804c08bc8832435838ed5e0b02a84cab6c /meson.build
parent50b82ca81810447954295bc792e0c7515cf12a9c (diff)
downloadmesa-89553408398766ef3afe949aead6e1c9b1e43961.tar.gz
meson: make GLX require OpenGL
This isn't strictly true, but making that work isn't worth the effort; see https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/21343#note_1774683 Suggested-by: Adam Jackson <ajax@redhat.com> Signed-off-by: Eric Engestrom <eric@igalia.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/21343>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 518d77b2b2f..affeca8c611 100644
--- a/meson.build
+++ b/meson.build
@@ -320,7 +320,9 @@ with_platform_windows = _platforms.contains('windows')
with_glx = get_option('glx')
if with_glx == 'auto'
- if with_platform_android
+ if not with_opengl
+ with_glx = 'disabled'
+ elif with_platform_android
with_glx = 'disabled'
elif with_dri
with_glx = 'dri'
@@ -345,6 +347,10 @@ if with_glx == 'dri'
endif
endif
+if not with_opengl and with_glx != 'disabled'
+ error('Building GLX without OpenGL is not supported.') \
+endif
+
if not (with_dri or with_gallium or with_glx != 'disabled')
with_gles1 = false
with_gles2 = false