summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan.c.baker@intel.com>2022-11-01 13:37:06 -0700
committerMarge Bot <emma+marge@anholt.net>2022-11-10 21:14:17 +0000
commit41a929d94ca58cf4e6256275687ce2e7da712ce9 (patch)
tree66b7319e3d646553a257f9d66109db021ec25b44 /meson.build
parentae30c6c375a43ee37a50ae0858c282072bcead61 (diff)
downloadmesa-41a929d94ca58cf4e6256275687ce2e7da712ce9.tar.gz
util/glsl2spirv: pass path to glslangValidator into the script
This allows users to override the location of glslang using normal meson mechanisms. Reviewed-by: Luis Felipe Strano Moraes <luis.strano@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19449>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6ecfc1c3088..59db762fba3 100644
--- a/meson.build
+++ b/meson.build
@@ -685,7 +685,7 @@ if vdpau_drivers_path == ''
vdpau_drivers_path = join_paths(get_option('libdir'), 'vdpau')
endif
-if with_vulkan_overlay_layer or with_aco_tests or with_amd_vk
+if with_vulkan_overlay_layer or with_aco_tests or with_amd_vk or with_intel_vk
prog_glslang = find_program('glslangValidator', native : true)
if run_command(prog_glslang, [ '--quiet', '--version' ], check : false).returncode() == 0
glslang_quiet = ['--quiet']