summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan.c.baker@intel.com>2022-11-01 13:35:24 -0700
committerMarge Bot <emma+marge@anholt.net>2022-11-10 21:14:17 +0000
commitae30c6c375a43ee37a50ae0858c282072bcead61 (patch)
treebd80d237b416ee073bfc1aec4551547ad670e661 /meson.build
parent9a85d2ed984fc9a6267861242d4ae12f2aae3d52 (diff)
downloadmesa-ae30c6c375a43ee37a50ae0858c282072bcead61.tar.gz
meson: prog_glslang should always be for the build machine
It doesn't produce different code when compiled for the host machine, and this avoids needing two copies and possibly a host machine emulator in cross compilation settings Reviewed-by: Luis Felipe Strano Moraes <luis.strano@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19449>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3e46cd50deb..6ecfc1c3088 100644
--- a/meson.build
+++ b/meson.build
@@ -686,7 +686,7 @@ if vdpau_drivers_path == ''
endif
if with_vulkan_overlay_layer or with_aco_tests or with_amd_vk
- prog_glslang = find_program('glslangValidator')
+ prog_glslang = find_program('glslangValidator', native : true)
if run_command(prog_glslang, [ '--quiet', '--version' ], check : false).returncode() == 0
glslang_quiet = ['--quiet']
else