summaryrefslogtreecommitdiff
path: root/zephyr/test/kingler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/kingler/CMakeLists.txt')
-rw-r--r--zephyr/test/kingler/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/zephyr/test/kingler/CMakeLists.txt b/zephyr/test/kingler/CMakeLists.txt
new file mode 100644
index 0000000000..eaaf04fe4d
--- /dev/null
+++ b/zephyr/test/kingler/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Copyright 2022 The ChromiumOS Authors.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+cmake_minimum_required(VERSION 3.13.1)
+find_package(Zephyr REQUIRED HINTS "${ZEPHYR_BASE}")
+project(kingler)
+
+target_sources(app PRIVATE ${PLATFORM_EC}/zephyr/projects/corsola/src/kingler/board_steelix.c)
+
+target_sources(app PRIVATE src/fakes.c)
+
+target_sources_ifdef(CONFIG_TEST_FORM_FACTOR_CONVERTIBLE
+ app PRIVATE src/tablet.c)
+target_sources_ifdef(CONFIG_TEST_FORM_FACTOR_CLAMSHELL
+ app PRIVATE src/clamshell.c)