summaryrefslogtreecommitdiff
path: root/zephyr/test/kingler/CMakeLists.txt
diff options
context:
space:
mode:
authorJeremy Bettis <jbettis@google.com>2022-08-16 11:13:21 -0600
committerChromeos LUCI <chromeos-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-08-17 22:35:12 +0000
commit96af58d5d8e438628342bca6458d8cd2987df7b6 (patch)
treed13fb3d854f33baf1d0c6e8e8c9e8e17926b6f24 /zephyr/test/kingler/CMakeLists.txt
parentb37f579fdaa277bc0b89fd255fa2a7535f06e24d (diff)
downloadchrome-ec-release-R106-15054.B-main.tar.gz
zephyr: Added test for steelix board specific coderelease-R106-15054.B-main
Add a dts file for native_posix tests that want to use npcx gpios and interrupts. There is more work to be done to make it full featured. Specifically the npcx pinctrl driver really needs an emulator. Add test for the board specific code in steelix. This is mostly a sample on how to do this, more than being that useful of a test on it's own. BRANCH=None BUG=b:242032118 TEST=./twister --coverage -T zephyr/test/kingler Signed-off-by: Jeremy Bettis <jbettis@google.com> Change-Id: I9436a447e7cd4f3baa743c77d4b2d89bafeb0c9c Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3833914 Tested-by: Jeremy Bettis <jbettis@chromium.org> Commit-Queue: Jeremy Bettis <jbettis@chromium.org> Reviewed-by: Yuval Peress <peress@google.com> Reviewed-by: Simon Glass <sjg@chromium.org> Auto-Submit: Jeremy Bettis <jbettis@chromium.org> Code-Coverage: Zoss <zoss-cl-coverage@prod.google.com>
Diffstat (limited to 'zephyr/test/kingler/CMakeLists.txt')
-rw-r--r--zephyr/test/kingler/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/zephyr/test/kingler/CMakeLists.txt b/zephyr/test/kingler/CMakeLists.txt
new file mode 100644
index 0000000000..eaaf04fe4d
--- /dev/null
+++ b/zephyr/test/kingler/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Copyright 2022 The ChromiumOS Authors.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+cmake_minimum_required(VERSION 3.13.1)
+find_package(Zephyr REQUIRED HINTS "${ZEPHYR_BASE}")
+project(kingler)
+
+target_sources(app PRIVATE ${PLATFORM_EC}/zephyr/projects/corsola/src/kingler/board_steelix.c)
+
+target_sources(app PRIVATE src/fakes.c)
+
+target_sources_ifdef(CONFIG_TEST_FORM_FACTOR_CONVERTIBLE
+ app PRIVATE src/tablet.c)
+target_sources_ifdef(CONFIG_TEST_FORM_FACTOR_CLAMSHELL
+ app PRIVATE src/clamshell.c)