summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build23
1 files changed, 21 insertions, 2 deletions
diff --git a/data/meson.build b/data/meson.build
index 04cfc15..6cdfea5 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -22,6 +22,25 @@ if desktop_file_validate_prg.found()
)
endif
-# manpage
+# manpage -- generated from help2man
-install_man('zenity.1')
+help2man = find_program('help2man', required: false)
+# help2man has to run zenity to generate the man page, which it can't do if
+# we're cross building. We also can't tell help2man what exe wrapper to use.
+if help2man.found() and not meson.is_cross_build()
+ help2man_opts = [
+ '--no-info',
+ '--section=1',
+ '--help-option=--help-all',
+ '--include=@INPUT@',
+ ]
+
+ custom_target('zenity.1',
+ output: 'zenity.1',
+ input: 'zenity.roff',
+ command: [
+ help2man, help2man_opts, '--output=@OUTPUT@', zenity
+ ],
+ install: true,
+ install_dir: join_paths(zenity_mandir, 'man1'))
+endif