summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorLogan Rathbone <poprocks@gmail.com>2023-01-25 17:07:35 +0000
committerLogan Rathbone <poprocks@gmail.com>2023-01-25 17:07:35 +0000
commita0c55e36136eb4469156f57877829ea39c016cbb (patch)
tree16764729f29839281597dc7d8ab332cfc81bcd4b /data/meson.build
parent7e3cf22aba795935154c25e65e6fe8bc2895f05c (diff)
parent008c677ec2546cf9c3c267d9f1df0d248b41c630 (diff)
downloadzenity-gtk4-port.tar.gz
Merge branch 'libadwaita-port' into 'gtk4-port'3.90.0gtk4-port
zenity4: Port to libadwaita/AdwMessageDialog See merge request GNOME/zenity!22
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build23
1 files changed, 21 insertions, 2 deletions
diff --git a/data/meson.build b/data/meson.build
index 04cfc15..6cdfea5 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -22,6 +22,25 @@ if desktop_file_validate_prg.found()
)
endif
-# manpage
+# manpage -- generated from help2man
-install_man('zenity.1')
+help2man = find_program('help2man', required: false)
+# help2man has to run zenity to generate the man page, which it can't do if
+# we're cross building. We also can't tell help2man what exe wrapper to use.
+if help2man.found() and not meson.is_cross_build()
+ help2man_opts = [
+ '--no-info',
+ '--section=1',
+ '--help-option=--help-all',
+ '--include=@INPUT@',
+ ]
+
+ custom_target('zenity.1',
+ output: 'zenity.1',
+ input: 'zenity.roff',
+ command: [
+ help2man, help2man_opts, '--output=@OUTPUT@', zenity
+ ],
+ install: true,
+ install_dir: join_paths(zenity_mandir, 'man1'))
+endif