summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e705550..475f4bb 100644
--- a/meson.build
+++ b/meson.build
@@ -6,6 +6,11 @@ project('yelp-tools',
gnome = import('gnome')
+python = import('python')
+pyinst = python.find_installation('python3', required: true)
+lxml = run_command('python3', '-c', 'import lxml')
+assert(lxml.returncode() == 0, 'Python module `lxml` required')
+
# Versioning
version = meson.project_version()
version_arr = version.split('.')