summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorShaun McCance <shaunm@redhat.com>2021-02-01 20:03:22 -0500
committerShaun McCance <shaunm@redhat.com>2021-02-01 20:03:22 -0500
commita97c9ed35baa68ddefa8034cf97e13718034a246 (patch)
treeee9743a39eae159318cbfdf72db1185b89814b0f /meson.build
parentab19610426aeb43e000294e790ab3cd1eab9b146 (diff)
downloadyelp-tools-a97c9ed35baa68ddefa8034cf97e13718034a246.tar.gz
Switch to new python tools
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e705550..475f4bb 100644
--- a/meson.build
+++ b/meson.build
@@ -6,6 +6,11 @@ project('yelp-tools',
gnome = import('gnome')
+python = import('python')
+pyinst = python.find_installation('python3', required: true)
+lxml = run_command('python3', '-c', 'import lxml')
+assert(lxml.returncode() == 0, 'Python module `lxml` required')
+
# Versioning
version = meson.project_version()
version_arr = version.split('.')