summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Waldmann <tw AT waldmann-edv DOT de@localhost>2011-06-26 16:21:54 +0200
committerThomas Waldmann <tw AT waldmann-edv DOT de@localhost>2011-06-26 16:21:54 +0200
commitf02c207e191e53196d6df4369a3d69d9c31a01cd (patch)
tree39047cc4dc5b7b0a6452a89410e2c538a708c3a9
parentb34a7ff85609750c513d1a7694b18e0ccaa30c23 (diff)
downloadxstatic-jquery-git-f02c207e191e53196d6df4369a3d69d9c31a01cd.tar.gz
fix import issue that happened at setup.py import time
-rw-r--r--xstatic/pkg/jquery/__init__.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/xstatic/pkg/jquery/__init__.py b/xstatic/pkg/jquery/__init__.py
index fa393e7..44b2821 100644
--- a/xstatic/pkg/jquery/__init__.py
+++ b/xstatic/pkg/jquery/__init__.py
@@ -4,7 +4,14 @@ jQuery package
from os.path import join, dirname
-from xstatic.main import XStatic
+try:
+ from xstatic.main import XStatic
+except ImportError:
+ class XStatic(object):
+ """
+ just a dummy for the time when setup.py is running and
+ for the case that xstatic is not already installed.
+ """
class JQuery(XStatic):
name = 'jquery' # short, all lowercase name