summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Waldmann <tw AT waldmann-edv DOT de@localhost>2011-06-26 12:21:01 +0200
committerThomas Waldmann <tw AT waldmann-edv DOT de@localhost>2011-06-26 12:21:01 +0200
commitb34a7ff85609750c513d1a7694b18e0ccaa30c23 (patch)
tree9efb92ec9032d780a1ebbe86d81ba2b2511bd2f7
parent593637ef0aecd914d76b4a61d86c87239bfeeca3 (diff)
downloadxstatic-jquery-git-b34a7ff85609750c513d1a7694b18e0ccaa30c23.tar.gz
minor metadata / comments cleanups / fixes
-rw-r--r--setup.py6
-rw-r--r--xstatic/pkg/jquery/__init__.py19
2 files changed, 15 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 746d00a..6a1920b 100644
--- a/setup.py
+++ b/setup.py
@@ -7,13 +7,13 @@ from xstatic.pkg.jquery import JQuery as xs
long_description = open('README.txt').read()
-setup( # better now, though not all of these make sense outside of setup.py
+setup(
name='XStatic-' + xs.display_name,
version=xs.version,
description=xs.description,
long_description=long_description,
- classifiers=xs.classifiers, # for pypi
- keywords=xs.keywords, # for pypi
+ classifiers=xs.classifiers,
+ keywords=xs.keywords,
author=xs.author,
author_email=xs.author_email,
license=xs.license,
diff --git a/xstatic/pkg/jquery/__init__.py b/xstatic/pkg/jquery/__init__.py
index ef24a27..fa393e7 100644
--- a/xstatic/pkg/jquery/__init__.py
+++ b/xstatic/pkg/jquery/__init__.py
@@ -1,5 +1,5 @@
"""
-jQuery package (following xstatic standard)
+jQuery package
"""
from os.path import join, dirname
@@ -12,22 +12,27 @@ class JQuery(XStatic):
version = '1.6.1' # for simplicity, use same version as bundled files
base_dir = join(dirname(__file__), 'data')
+ # linux package maintainers just can point to their file locations like this:
# base_dir = '/usr/share/javascript/jquery'
- description = "%s (xstatic packaging standard)" % display_name
+ description = "%s (XStatic packaging standard)" % display_name
platforms = 'any'
classifiers = []
keywords = '%s xstatic' % name
# this all refers to the XStatic-* package:
- author = 'xstatic developers'
- author_email = 'xstatic@example.org'
- license = '(same a %s)' % display_name
- homepage = 'http://xstatic.example.org/'
-
+ author = 'Thomas Waldmann'
+ author_email = 'tw@waldmann-edv.de'
# XXX shall we have another bunch of entries for the bundled files?
# like upstream_author/homepage/download/...?
+ # note: distutils/register can't handle author and maintainer at once.
+
+ # this refers to the project homepage of the stuff we packaged:
+ homepage = 'http://jquery.com/'
+
+ # this refers to all files:
+ license = '(same a %s)' % display_name
locations = {
# if value is a string, it is a base location, just append relative