summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 176d22e..f747a3d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,18 @@ AC_LINK_IFELSE(
[libinput_have_scroll_button_lock=yes]],
[AC_MSG_RESULT([no])
[libinput_have_scroll_button_lock=no]])
+
+AC_MSG_CHECKING([if libinput_event_pointer_get_scroll_value_v120 is available])
+AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([[#include <libinput.h>]],
+ [[libinput_event_pointer_get_scroll_value_v120(NULL, 0)]])],
+ [AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_LIBINPUT_AXIS_VALUE_V120, [1],
+ [libinput_event_pointer_get_scroll_value_v120() is available])
+ [libinput_have_axis_value_v120=yes]],
+ [AC_MSG_RESULT([no])
+ [libinput_have_axis_value_v120=no]])
+
LIBS=$OLD_LIBS
CFLAGS=$OLD_CFLAGS