summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2019-01-23 20:07:37 +1000
committerJosé Expósito <jose.exposito89@gmail.com>2021-08-06 08:45:01 +0200
commitbeb94333e1450006942a7f0ee38bc2a2f5719238 (patch)
tree17b7c665f2d9c35d835f1ababd4f7158e5dea918 /configure.ac
parentca9042c7f08f8f0dc214b9cc19f3243728ec8c4a (diff)
downloadxorg-driver-xf86-input-libinput-beb94333e1450006942a7f0ee38bc2a2f5719238.tar.gz
Use the new v120 API from libinput if available
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 176d22e..f747a3d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,18 @@ AC_LINK_IFELSE(
[libinput_have_scroll_button_lock=yes]],
[AC_MSG_RESULT([no])
[libinput_have_scroll_button_lock=no]])
+
+AC_MSG_CHECKING([if libinput_event_pointer_get_scroll_value_v120 is available])
+AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([[#include <libinput.h>]],
+ [[libinput_event_pointer_get_scroll_value_v120(NULL, 0)]])],
+ [AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_LIBINPUT_AXIS_VALUE_V120, [1],
+ [libinput_event_pointer_get_scroll_value_v120() is available])
+ [libinput_have_axis_value_v120=yes]],
+ [AC_MSG_RESULT([no])
+ [libinput_have_axis_value_v120=no]])
+
LIBS=$OLD_LIBS
CFLAGS=$OLD_CFLAGS