summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-05-20 01:28:26 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-05-20 01:28:26 +0200
commite737024ca23de8e549bc4d9ab547420b8c990eee (patch)
treec28ea3e78d2ce6817f79b3cf54fffced9091e1b0 /tumbler/Makefile.am
parent4b7a4c0d14310b17e4c9f6597b7edc18421063fc (diff)
downloadtumbler-e737024ca23de8e549bc4d9ab547420b8c990eee.tar.gz
Add TumblerScheduler and TumblerThresholdScheduler skeletons.
Thumbnail requests need to be scheduled in some way. Let's say the service receives a request for 1000 thumbnails and one for 5 after the first one. How should these be scheduled? TumblerScheduler provides an interface for different schedulers, one of which is TumblerThresholdScheduler. TumblerThresholdScheduler is inspired by the thumbnailer in hildon-thumbnail. It uses two thread pools, one for large and one for small requests. Requests are managed using a LIFO and inserted into one of the pools depending on the number of requested thumbnails (the threshold). However, for the moment these are just skeletons. This commit also makes sure to copy hash keys before inserting thumbnailers into the registry hash table.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index 0336c37..492e343 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -35,10 +35,14 @@ tumbler_SOURCES = \
tumbler-manager.h \
tumbler-registry.c \
tumbler-registry.h \
+ tumbler-scheduler.c \
+ tumbler-scheduler.h \
tumbler-service.c \
tumbler-service.h \
tumbler-specialized-thumbnailer.c \
tumbler-specialized-thumbnailer.h \
+ tumbler-threshold-scheduler.c \
+ tumbler-threshold-scheduler.h \
tumbler-thumbnailer.c \
tumbler-thumbnailer.h \
tumbler-utils.h \