summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-05-19 02:39:47 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-05-19 02:39:47 +0200
commit4b7a4c0d14310b17e4c9f6597b7edc18421063fc (patch)
tree33559feca341adf6363bf11045d06f04de7205a3 /tumbler/Makefile.am
parentf35dd94216a946fe82dc9328dfaf6fdaca98d883 (diff)
downloadtumbler-4b7a4c0d14310b17e4c9f6597b7edc18421063fc.tar.gz
Use GdkPixbuf to get MIME types for the (optional) pixbuf thumbnailer.
Add an optional dependency on gdk-pixbuf-2.0 >= 2.14 for the pixbuf thumbnailer created with tumbler_pixbuf_thumbnailer_new(). Use gdk_pixbuf_get_formats() to get a list of formats and MIME types supported by GdkPixbuf. Pass these to the constructor of the thumbnailer.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index 9392dd3..0336c37 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -50,6 +50,7 @@ tumbler_CFLAGS = \
-I$(top_srcdir) \
$(DBUS_CFLAGS) \
$(DBUS_GLIB_CFLAGS) \
+ $(GDK_PIXBUF_CFLAGS) \
$(GIO_CFLAGS) \
$(GLIB_CFLAGS) \
$(GTHREAD_CFLAGS)
@@ -60,6 +61,7 @@ tumbler_LDFLAGS = \
tumbler_LDADD = \
$(DBUS_LIBS) \
$(DBUS_GLIB_LIBS) \
+ $(GDK_PIXBUF_LIBS) \
$(GIO_LIBS) \
$(GLIB_LIBS) \
$(GTHREAD_LIBS)