summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-05-18 05:12:38 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-05-18 05:12:38 +0200
commita66781a82678305cee2566f72cb0ea2c34667871 (patch)
tree3c30807ca0ff693b2ecf483747351a08c1ab45dd /tumbler/Makefile.am
parent74dfcce3515f3e9852570a1a01faa5d997c63f6d (diff)
downloadtumbler-a66781a82678305cee2566f72cb0ea2c34667871.tar.gz
Improve TumblerThumbnailer and add TumblerSpecializedThumbnailer.
Add new properties "uri-schemes" and "hash-keys" to TumblerThumbnailer and add getter functions for all TumblerThumbnailer properties. Add URI schemes parameter to the TumblerBuiltinThumbnailer constructor and compute hash keys for built-in thumbnailers based on the provided URI schemes and mime types. Adds TumblerSpecializedThumbnailer which is created for each thumbnailer either found in $XDG_DATA_DIRS/thumbnailers/ or registered dynamically via org.freedesktop.thumbnailer.Manager.Register(). Internally it uses a DBusGProxy to talk to the specialized thumbnailer service. Add a GMutex to TumblerManager and lock all functions for now. Implement the Register() method which creates a new TumblerSpecializedThumbnailer and adds it to the registry.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index c2580f4..9392dd3 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -37,6 +37,8 @@ tumbler_SOURCES = \
tumbler-registry.h \
tumbler-service.c \
tumbler-service.h \
+ tumbler-specialized-thumbnailer.c \
+ tumbler-specialized-thumbnailer.h \
tumbler-thumbnailer.c \
tumbler-thumbnailer.h \
tumbler-utils.h \