summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-05-17 22:10:57 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-05-17 22:10:57 +0200
commit74dfcce3515f3e9852570a1a01faa5d997c63f6d (patch)
treeac6657c76916bcb7ff93ff152bf50b602cde8e8c /tumbler/Makefile.am
parentabdd96f4ac9e04da0d58b2dfd144d661fdd02095 (diff)
downloadtumbler-74dfcce3515f3e9852570a1a01faa5d997c63f6d.tar.gz
Introduce interfaces and classes for built-in thumbnailers.
This commit introduces the TumblerThumbnailer interface which is supposed to be implemented twice, once for built-in thumbnailers that run in the same process as tumbler itself, and once for specialized thumbnailers which talk to tumbler over D-Bus. TumblerThumbnailer provides a function for creating a thumbnail plus "ready" and "error" signals. Their signatures may still change though. TumblerBuiltinThumbnailer is a new class for built-in thumbnailers. It is a little similar to ExoSimpleJob in that it allows built-in thumbnailers to be created by defining a create function and a list of mime types. Also new is tumbler_pixbuf_thumbnailer_new() which creates a pixbuf thumbnailer. It's just a skeleton for now. TumblerRegistry now has a method tumbler_registry_add() for adding a new TumblerThumbnailer to the registry. Last but not least, there's tumbler-marshal.list for custom marshallers now.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am32
1 files changed, 30 insertions, 2 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index 9bf77ee..c2580f4 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -21,16 +21,24 @@ libexec_PROGRAMS = \
tumbler
tumbler_built_sources = \
- tumbler-manager-dbus-bindings.h
+ tumbler-manager-dbus-bindings.h \
+ tumbler-marshal.c \
+ tumbler-marshal.h
tumbler_SOURCES = \
main.c \
+ tumbler-builtin-thumbnailers.c \
+ tumbler-builtin-thumbnailers.h \
+ tumbler-builtin-thumbnailer.c \
+ tumbler-builtin-thumbnailer.h \
tumbler-manager.c \
tumbler-manager.h \
tumbler-registry.c \
tumbler-registry.h \
tumbler-service.c \
tumbler-service.h \
+ tumbler-thumbnailer.c \
+ tumbler-thumbnailer.h \
tumbler-utils.h \
$(tumbler_built_sources)
@@ -65,16 +73,36 @@ CLEANFILES = \
$(service_DATA)
EXTRA_DIST = \
- $(service_in_files)
+ $(service_in_files) \
+ tumbler-manager-dbus.xml
if MAINTAINER_MODE
DISTCLEANFILES = \
+ stamp-tumbler-marshal.h \
$(tumbler_built_sources)
BUILT_SOURCES = \
$(tumbler_built_sources)
+tumbler-marshal.h: stamp-tumbler-marshal.h
+ @true
+
+stamp-tumbler-marshal.h: tumbler-marshal.list Makefile
+ ( cd $(srcdir) && glib-genmarshal \
+ --prefix=tumbler_marshal \
+ --header tumbler-marshal.list ) >> xgen-emh \
+ && ( cmp -s xgen-emh tumbler-marshal.h || cp xgen-emh tumbler-marshal.h ) \
+ && rm -f xgen-emh \
+ && echo timestamp > $(@F)
+
+tumbler-marshal.c: tumbler-marshal.list Makefile
+ ( cd $(srcdir) && glib-genmarshal \
+ --prefix=tumbler_marshal \
+ --body tumbler-marshal.list ) >> xgen-emc \
+ && cp xgen-emc tumbler-marshal.c \
+ && rm -f xgen-emc
+
tumbler-manager-dbus-bindings.h: tumbler-manager-dbus.xml Makefile
dbus-binding-tool --mode=glib-server --prefix=tumbler_manager $< > $@