summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-08-24 14:27:07 +0300
committerBryce Harrington <bryce@osg.samsung.com>2015-08-24 16:33:46 -0700
commitab81f1515a5ede0936166d0051208f7618c2aa9e (patch)
tree77eea28604e8042511664713326b6fe0f2d6ef88 /configure.ac
parentfaee330c5e027011941d50533156683be3a67ca3 (diff)
downloadweston-ab81f1515a5ede0936166d0051208f7618c2aa9e.tar.gz
build, compositor-drm: fix output name constants another way
Bumping libdrm requirement by 3 years just for output connector name constants was a bit much. Fix the problem introduced in 89c49b3060a115e846ba1e7fbef94d14894244f2 by conditionally using the new additions. Both VIRTUAL and DSI came in the same libdrm commit 566c3ce877a4be72697e15cdfc421ce965f7c37d, so we check only for DSI. This patch also reverts faee330c5e027011941d50533156683be3a67ca3. Reported-by: Eugen Friedrich <friedrix@gmail.com> Cc: Derek Foreman <derekf@osg.samsung.com> Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Reviewed-by: Derek Foreman <derekf@osg.samsung.com> Acked-by: Bryce Harrington <bryce@osg.samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d70777db..425f0715 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,7 +171,7 @@ AC_ARG_ENABLE(drm-compositor, [ --enable-drm-compositor],,
AM_CONDITIONAL(ENABLE_DRM_COMPOSITOR, test x$enable_drm_compositor = xyes)
if test x$enable_drm_compositor = xyes; then
AC_DEFINE([BUILD_DRM_COMPOSITOR], [1], [Build the DRM compositor])
- PKG_CHECK_MODULES(DRM_COMPOSITOR, [libudev >= 136 libdrm >= 2.4.59 gbm mtdev >= 1.1.0])
+ PKG_CHECK_MODULES(DRM_COMPOSITOR, [libudev >= 136 libdrm >= 2.4.30 gbm mtdev >= 1.1.0])
PKG_CHECK_MODULES(DRM_COMPOSITOR_GBM, [gbm >= 10.2],
[AC_DEFINE([HAVE_GBM_FD_IMPORT], 1, [gbm supports dmabuf import])],
[AC_MSG_WARN([gbm does not support dmabuf import, will omit that capability])])