summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDerek Foreman <derekf@osg.samsung.com>2015-08-21 23:06:02 -0500
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-08-24 11:45:41 +0300
commitfaee330c5e027011941d50533156683be3a67ca3 (patch)
tree017dcd67c28cc09037cf215404170e93bf038eae /configure.ac
parentdecc965be93b25ce2025a125a9d437269cbf0a0e (diff)
downloadweston-faee330c5e027011941d50533156683be3a67ca3.tar.gz
build: Require newer version of libdrm
commit 89c49b3060a115e846ba1e7fbef94d14894244f2 changed the way we name outputs, but it also added the new output names VIRTUAL and DSI. These aren't available until libdrm 2.4.59 Signed-off-by: Derek Foreman <derekf@osg.samsung.com> Reviewed-by: Bryce Harrington <bryce@osg.samsung.com> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 425f0715..d70777db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,7 +171,7 @@ AC_ARG_ENABLE(drm-compositor, [ --enable-drm-compositor],,
AM_CONDITIONAL(ENABLE_DRM_COMPOSITOR, test x$enable_drm_compositor = xyes)
if test x$enable_drm_compositor = xyes; then
AC_DEFINE([BUILD_DRM_COMPOSITOR], [1], [Build the DRM compositor])
- PKG_CHECK_MODULES(DRM_COMPOSITOR, [libudev >= 136 libdrm >= 2.4.30 gbm mtdev >= 1.1.0])
+ PKG_CHECK_MODULES(DRM_COMPOSITOR, [libudev >= 136 libdrm >= 2.4.59 gbm mtdev >= 1.1.0])
PKG_CHECK_MODULES(DRM_COMPOSITOR_GBM, [gbm >= 10.2],
[AC_DEFINE([HAVE_GBM_FD_IMPORT], 1, [gbm supports dmabuf import])],
[AC_MSG_WARN([gbm does not support dmabuf import, will omit that capability])])