summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBryce Harrington <bryce@osg.samsung.com>2015-08-14 12:23:13 -0700
committerBryce Harrington <bryce@osg.samsung.com>2015-08-14 12:45:11 -0700
commita358207572f3fb98e42128aeeb71cb9fea3d2b23 (patch)
treeeb9afecb72e8efa8ec503047fe6aed1de8b11c12 /configure.ac
parent53868985ff20badbcb70c69055937893fde1d91d (diff)
downloadweston-a358207572f3fb98e42128aeeb71cb9fea3d2b23.tar.gz
Fix build breakage when using older gbm lacking dmabuf import
The buildbots discovered this issue on Ubuntu 14.04, which carries libgbm 10.1.3-0ubuntu0.4. The dmabuf changes need gbm 10.2, so it fails during build like this: src/compositor-drm.c: In function ‘drm_output_prepare_overlay_view’: src/compositor-drm.c:984:10: error: variable ‘gbm_dmabuf’ has initializer but incomplete type struct gbm_import_fd_data gbm_dmabuf = { ^ etc. Proposed fix is to conditionalize the gbm fd import feature in compositor-drm. This fix was suggested by daniels. I set up a synthetic test environment to reproduce the issue as found by the buildbots and tweaked the patch to get it to build both with and without gbm 10.2. Signed-off-by: Bryce Harrington <bryce@osg.samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0f745817..e610e2d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,6 +172,9 @@ AM_CONDITIONAL(ENABLE_DRM_COMPOSITOR, test x$enable_drm_compositor = xyes)
if test x$enable_drm_compositor = xyes; then
AC_DEFINE([BUILD_DRM_COMPOSITOR], [1], [Build the DRM compositor])
PKG_CHECK_MODULES(DRM_COMPOSITOR, [libudev >= 136 libdrm >= 2.4.30 gbm mtdev >= 1.1.0])
+ PKG_CHECK_MODULES(DRM_COMPOSITOR_GBM, [gbm >= 10.2],
+ [AC_DEFINE([HAVE_GBM_FD_IMPORT], 1, [gbm supports dmabuf import])],
+ [AC_MSG_WARN([gbm does not support dmabuf import, will omit that capability])])
fi