summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2014-06-12 16:26:49 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-08-14 15:53:26 +0300
commit53868985ff20badbcb70c69055937893fde1d91d (patch)
treefcb1ad34ff661e0a19d6307aeb1abee1b119dd69 /configure.ac
parentbf8cc6f5a12f34596d2e9ae002f45eefc007c481 (diff)
downloadweston-53868985ff20badbcb70c69055937893fde1d91d.tar.gz
clients: add simple-dmabuf client
v2: - adapted to protocol changes - added TODO comments - minor clean-up - change y-invert from per-plane boolean to per-buffer flag v3: - fix a typo: 1 -> i (noticed by Carlos Olmedo Escobar) Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com> Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Signed-off-by: Louis-Francis Ratté-Boulianne <lfrb@collabora.com> Acked-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6c77826a..0f745817 100644
--- a/configure.ac
+++ b/configure.ac
@@ -335,6 +335,15 @@ if test x$enable_simple_egl_clients = xyes; then
[egl >= 7.10 glesv2 wayland-client wayland-egl wayland-cursor])
fi
+AC_ARG_ENABLE(simple-intel-dmabuf-client,
+ AS_HELP_STRING([--disable-simple-intel-dmabuf-client],
+ [do not build the simple intel dmabuf client]),,
+ enable_simple_intel_dmabuf_client="yes")
+AM_CONDITIONAL(BUILD_SIMPLE_INTEL_DMABUF_CLIENT, test "x$enable_simple_intel_dmabuf_client" = "xyes")
+if test "x$enable_simple_intel_dmabuf_client" = "xyes"; then
+ PKG_CHECK_MODULES(SIMPLE_DMABUF_CLIENT, [wayland-client libdrm libdrm_intel])
+fi
+
AC_ARG_ENABLE(clients, [ --enable-clients],, enable_clients=yes)
AM_CONDITIONAL(BUILD_CLIENTS, test x$enable_clients = xyes)
if test x$enable_clients = xyes; then