summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJasper St. Pierre <jstpierre@mecheye.net>2015-09-23 10:46:47 -0700
committerBryce Harrington <bryce@osg.samsung.com>2015-09-23 15:47:48 -0700
commit72dea06d7952e3ce8dd8057f7106186da4fa2678 (patch)
tree8a0489865638fb2e28db57786ac0c1b5b5f9812b /Makefile.am
parent30bcf35ceba29f070bc8eb7286e9b89eb85405be (diff)
downloadweston-72dea06d7952e3ce8dd8057f7106186da4fa2678.tar.gz
launcher: Split out launcher implementations into three distinct ones
We now have a launcher interface and distinct implementations for logind, weston-launch, and direct DRM, each in their own files. This helps up clean up the spaghetti code into something that's hopefully a bit more understood. There should be no functional changes here. Reviewed-by: Derek Foreman <derekf@osg.samsung.com> update: Dropped redundant free() in weston_launcher_destroy()
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 79a442cd..94a824be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -127,9 +127,11 @@ noinst_LTLIBRARIES += \
libsession-helper.la
libsession_helper_la_SOURCES = \
- src/weston-launch.h \
src/launcher-util.c \
- src/launcher-util.h
+ src/launcher-util.h \
+ src/weston-launch.h \
+ src/launcher-weston-launch.c \
+ src/launcher-direct.c
libsession_helper_la_CFLAGS = $(AM_CFLAGS) $(LIBDRM_CFLAGS) $(PIXMAN_CFLAGS) $(COMPOSITOR_CFLAGS)
libsession_helper_la_LIBADD = $(LIBDRM_LIBS)
@@ -138,7 +140,6 @@ if HAVE_SYSTEMD_LOGIN
libsession_helper_la_SOURCES += \
src/dbus.h \
src/dbus.c \
- src/launcher-logind.h \
src/launcher-logind.c
libsession_helper_la_CFLAGS += $(SYSTEMD_LOGIN_CFLAGS) $(DBUS_CFLAGS)
libsession_helper_la_LIBADD += $(SYSTEMD_LOGIN_LIBS) $(DBUS_LIBS)