summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJon A. Cruz <jonc@osg.samsung.com>2015-07-15 19:22:41 -0700
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-07-17 13:27:39 +0300
commit646aef543ec26a927da5bc0a1dfa1494e95a30a9 (patch)
treefc53ef4cc96c6b7fc00f2af93a6a51a0fc30cb9d /Makefile.am
parent315476fa7b1f1c44c1b35116036df54ac5cb9a03 (diff)
downloadweston-646aef543ec26a927da5bc0a1dfa1494e95a30a9.tar.gz
Enables output in the JUnit XML format.
Adds basic support for optionally outputting in the XML format commonly used by JUnit compatible tools. This format is supported by default by many tools, including the Jenkins build system. It also is more detailed and captures more information than the more simplistic TAP format. Signed-off-by: Jon A. Cruz <jonc@osg.samsung.com> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d7b45a84..8f2cda3e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -984,6 +984,8 @@ libzunitc_la_SOURCES = \
tools/zunitc/src/zuc_context.h \
tools/zunitc/src/zuc_event.h \
tools/zunitc/src/zuc_event_listener.h \
+ tools/zunitc/src/zuc_junit_reporter.c \
+ tools/zunitc/src/zuc_junit_reporter.h \
tools/zunitc/src/zuc_types.h \
tools/zunitc/src/zunitc_impl.c \
shared/helpers.h
@@ -995,6 +997,13 @@ libzunitc_la_CFLAGS = \
libzunitc_la_LIBADD = \
libshared.la
+if ENABLE_JUNIT_XML
+libzunitc_la_CFLAGS += \
+ $(LIBXML2_CFLAGS)
+libzunitc_la_LIBADD += \
+ $(LIBXML2_LIBS)
+endif
+
libzunitcmain_la_SOURCES = \
tools/zunitc/src/main.c