summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-07-16 20:56:32 +0100
committerBryce Harrington <bryce@osg.samsung.com>2015-07-16 19:45:16 -0700
commit315476fa7b1f1c44c1b35116036df54ac5cb9a03 (patch)
tree69ad2a27ff743db34f3a206c64b8da7ff0f2abab /Makefile.am
parent2217f3f7383d814ef73d343f1337e43b3a71a90a (diff)
downloadweston-315476fa7b1f1c44c1b35116036df54ac5cb9a03.tar.gz
build: don't duplicate rule for weston.desktop
dist_wayland_session_DATA will distribute and install src/weston.desktop, so the definition of wayland_session_DATA which also installs src/weston.desktop will result in the file being installed twice and (rarely) cause install to fail. Spotted and fix by Roy Li <rongqing.li@windriver.com>. Signed-off-by: Ross Burton <ross.burton@intel.com> Reviewed-By: Derek Foreman <derekf@osg.samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f71587f5..d7b45a84 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -182,8 +182,7 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = src/weston.pc
wayland_sessiondir = $(datadir)/wayland-sessions
-wayland_session_DATA = src/weston.desktop
-dist_wayland_session_DATA = $(wayland_session_DATA)
+dist_wayland_session_DATA = src/weston.desktop
westonincludedir = $(includedir)/weston
westoninclude_HEADERS = \