summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJon A. Cruz <jonc@osg.samsung.com>2015-07-15 19:22:43 -0700
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-07-17 13:28:02 +0300
commit179c186e19d76a8e3057d653998fe38d0ba3791f (patch)
tree38545135e0186799eec32fc84ee37ff8477a32e5 /Makefile.am
parenta67c541e275da256fdb6bd6e3b86e139ce5ea6a5 (diff)
downloadweston-179c186e19d76a8e3057d653998fe38d0ba3791f.tar.gz
Adding doxygen setup and info for the testing framework.
Signed-off-by: Jon A. Cruz <jonc@osg.samsung.com> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e8b76c26..a3590c06 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1058,6 +1058,7 @@ WESTON_LOG_COMPILER = $(srcdir)/tests/weston-tests-env
clean-local:
-rm -rf logs
+ -rm -rf $(DOCDIRS)
# To remove when automake 1.11 support is dropped
export abs_builddir
@@ -1352,6 +1353,27 @@ EXTRA_DIST += \
CLEANFILES += $(man_MANS)
+if ENABLE_DEVDOCS
+DOXYGEN_INDICES = docs/developer/html/index.html docs/tools/html/index.html
+
+docs/developer/html/index.html: doc/doxygen/tooldev.doxygen | docs/developer
+ cd doc/doxygen && $(DOXYGEN) tooldev.doxygen
+
+docs/tools/html/index.html: doc/doxygen/tools.doxygen | docs/tools
+ cd doc/doxygen && $(DOXYGEN) tools.doxygen
+endif
+
+DOCDIRS = \
+ docs/developer \
+ docs/tools
+
+$(DOCDIRS):
+ $(MKDIR_P) $@
+
+.PHONY: doc $(DOXYGEN_INDICES)
+
+doc: $(DOXYGEN_INDICES)
+
protocol/%-protocol.c : $(top_srcdir)/protocol/%.xml
$(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(wayland_scanner) code < $< > $@