summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000..bf68bd39a
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,38 @@
+NULL =
+
+if ENABLE_VAPIGEN
+VAPIGEN_SUBDIRS = \
+ gobject-introspection \
+ vapigen \
+ $(NULL)
+endif
+
+SUBDIRS = \
+ ccode \
+ vala \
+ compiler \
+ vapi \
+ tests \
+ doc \
+ $(VAPIGEN_SUBDIRS)
+ $(NULL)
+
+DIST_SUBDIRS = \
+ ccode \
+ vala \
+ compiler \
+ vapi \
+ tests \
+ doc \
+ gobject-introspection \
+ vapigen \
+ $(NULL)
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = vala-1.0.pc
+
+EXTRA_DIST = \
+ MAINTAINERS \
+ vala-1.0.pc.in \
+ $(NULL)
+