summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJürg Billeter <j@bitron.ch>2007-05-02 09:42:00 +0000
committerJürg Billeter <juergbi@src.gnome.org>2007-05-02 09:42:00 +0000
commitf8387ad143f1884f8f5f89bd5389605624f4c34f (patch)
treee75e563fc9535200ec146af72962e80778359ae4 /Makefile.am
parent9db973114ee1449c1764404163ecc8294f8e73d2 (diff)
downloadvala-f8387ad143f1884f8f5f89bd5389605624f4c34f.tar.gz
Move contents of vala-pkg to trunk
2007-05-02 Jürg Billeter <j@bitron.ch> * Move contents of vala-pkg to trunk svn path=/trunk/; revision=300
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000..bf68bd39a
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,38 @@
+NULL =
+
+if ENABLE_VAPIGEN
+VAPIGEN_SUBDIRS = \
+ gobject-introspection \
+ vapigen \
+ $(NULL)
+endif
+
+SUBDIRS = \
+ ccode \
+ vala \
+ compiler \
+ vapi \
+ tests \
+ doc \
+ $(VAPIGEN_SUBDIRS)
+ $(NULL)
+
+DIST_SUBDIRS = \
+ ccode \
+ vala \
+ compiler \
+ vapi \
+ tests \
+ doc \
+ gobject-introspection \
+ vapigen \
+ $(NULL)
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = vala-1.0.pc
+
+EXTRA_DIST = \
+ MAINTAINERS \
+ vala-1.0.pc.in \
+ $(NULL)
+