summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2017-08-27 16:03:03 +0200
committerRico Tzschichholz <ricotz@ubuntu.com>2018-10-08 10:30:50 +0200
commit1dae711f17473e12c822a657ffca02abee27b3a2 (patch)
tree920f52f7defdf28aa75d8b0d87f25660ec90722b /Makefile.am
parent2eee4d0db7657800acbc7a926d48234465ed4e21 (diff)
downloadvala-1dae711f17473e12c822a657ffca02abee27b3a2.tar.gz
build: Allow disabling the build of valadoc
Allow disabling build of valadoc with configure option --disable-valadoc Fixes https://gitlab.gnome.org/GNOME/vala/issues/596
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 88bef90ed..e4d46741f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,9 +13,19 @@ SUBDIRS = \
doc \
gobject-introspection \
vapigen \
+ $(NULL)
+
+if ENABLE_VALADOC
+SUBDIRS += \
libvaladoc \
valadoc \
$(NULL)
+endif
+
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-valadoc \
+ --enable-unversioned \
+ $(NULL)
if ENABLE_UNVERSIONED
aclocaldir = $(datadir)/aclocal