summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2018-09-26 09:48:11 +0200
committerRico Tzschichholz <ricotz@ubuntu.com>2018-09-26 12:25:35 +0200
commit2eee4d0db7657800acbc7a926d48234465ed4e21 (patch)
tree599975f824371839683771609443916fc3227919 /Makefile.am
parent3777c1e22660c4b140a41877f070abaed845e8ff (diff)
downloadvala-2eee4d0db7657800acbc7a926d48234465ed4e21.tar.gz
build: Unconditionally add conditional VALAFLAGS to make bootstrap
This avoids another configure pass after an initial build with an older valac <= 0.39.5.8. See https://gitlab.gnome.org/GNOME/gnome-build-meta/issues/44
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 508c6618f..88bef90ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,7 +31,8 @@ libvala@PACKAGE_SUFFIX@.pc: libvala.pc
.PHONY: bootstrap
bootstrap: all
find $(top_srcdir) -name "*.vala.stamp" | xargs rm -f
- $(MAKE) $(AM_MAKEFLAGS) all VALAC=$(abs_top_builddir)/compiler/valac$(EXEEXT) V=$V
+ $(MAKE) $(AM_MAKEFLAGS) all VALAC=$(abs_top_builddir)/compiler/valac$(EXEEXT) V=$V \
+ VALAFLAGS="$(VALAFLAGS) --hide-internal --abi-stability"
.PHONY: test
test: