summaryrefslogtreecommitdiff
path: root/test/netstd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/netstd/Makefile.am')
-rw-r--r--test/netstd/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/test/netstd/Makefile.am b/test/netstd/Makefile.am
new file mode 100644
index 000000000..376ffb71e
--- /dev/null
+++ b/test/netstd/Makefile.am
@@ -0,0 +1,41 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+SUBDIRS = .
+
+all-local:
+ $(DOTNETCORE) build
+
+precross:
+ $(DOTNETCORE) build
+
+clean-local:
+ $(RM) -r Client/bin
+ $(RM) -r Server/bin
+ $(RM) -r Client/obj
+ $(RM) -r Server/obj
+ $(RM) -r ThriftTest/ThriftTest
+
+EXTRA_DIST = \
+ Client \
+ README.md \
+ Server \
+ ThriftTest.sln \
+ build.cmd \
+ build.sh