summaryrefslogtreecommitdiff
path: root/test/netstd/Makefile.am
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2019-01-28 23:27:45 +0100
committerJens Geyer <jensg@apache.org>2019-01-28 23:12:28 +0100
commitaa0c8b35d8f78812de1d7803d6277a37d2ed593a (patch)
treeb71ac06b6da5c135b11aea72bf12207e9cce0c2b /test/netstd/Makefile.am
parent1231930abd1d72b422deec967559caf3dc02dac7 (diff)
downloadthrift-aa0c8b35d8f78812de1d7803d6277a37d2ed593a.tar.gz
THRIFT-4723 Consolidate C#/netcore into new netstd language target
Client: netstd Patch: Jens Geyer This closes #1710
Diffstat (limited to 'test/netstd/Makefile.am')
-rw-r--r--test/netstd/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/test/netstd/Makefile.am b/test/netstd/Makefile.am
new file mode 100644
index 000000000..376ffb71e
--- /dev/null
+++ b/test/netstd/Makefile.am
@@ -0,0 +1,41 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+SUBDIRS = .
+
+all-local:
+ $(DOTNETCORE) build
+
+precross:
+ $(DOTNETCORE) build
+
+clean-local:
+ $(RM) -r Client/bin
+ $(RM) -r Server/bin
+ $(RM) -r Client/obj
+ $(RM) -r Server/obj
+ $(RM) -r ThriftTest/ThriftTest
+
+EXTRA_DIST = \
+ Client \
+ README.md \
+ Server \
+ ThriftTest.sln \
+ build.cmd \
+ build.sh