summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Molteni <marco.molteni@laposte.net>2015-04-15 21:22:41 +0200
committerRoger Meier <roger@apache.org>2015-04-15 22:04:49 +0200
commitfdf0198103fddf9cd43955da5eee9dc4c02ef9b4 (patch)
tree15eebdf541160235cb345e8e113f88c19e0c880a /CMakeLists.txt
parent7f47792bf288c3dca049d04de06d57d2f060abba (diff)
downloadthrift-fdf0198103fddf9cd43955da5eee9dc4c02ef9b4.tar.gz
THRIFT-3097 cmake targets unconditionally depend on optional libraries Consider also cases of missing ZLIB and missing OpenSSL.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f19f99972..386a63db9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,10 +75,10 @@ endif()
if(WITH_CPP)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/cpp)
if(BUILD_TESTING)
- if(WITH_LIBEVENT)
+ if(WITH_LIBEVENT AND WITH_ZLIB AND WITH_OPENSSL)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/test/cpp)
else()
- message(WARNING "libevent not found or disabled; will not build some tests")
+ message(WARNING "libevent and/or ZLIB and/or OpenSSL not found or disabled; will not build some tests")
endif()
endif()
endif()