summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Molteni <marco.molteni@laposte.net>2015-04-15 20:46:48 +0200
committerRoger Meier <roger@apache.org>2015-04-15 22:04:49 +0200
commit7f47792bf288c3dca049d04de06d57d2f060abba (patch)
tree78308529c1b194d87600c2eaf6c30d8b8442f80c /CMakeLists.txt
parenta242c28ba16012ba480c5fbac88bedceaf3aed57 (diff)
downloadthrift-7f47792bf288c3dca049d04de06d57d2f060abba.tar.gz
THRIFT-3097 cmake targets unconditionally depend on optional libraries
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2800167eb..f19f99972 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,7 +75,11 @@ endif()
if(WITH_CPP)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/cpp)
if(BUILD_TESTING)
- add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/test/cpp)
+ if(WITH_LIBEVENT)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/test/cpp)
+ else()
+ message(WARNING "libevent not found or disabled; will not build some tests")
+ endif()
endif()
endif()