summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e43dcf7d50..dfe1ff17b3 100644
--- a/meson.build
+++ b/meson.build
@@ -2140,13 +2140,16 @@ foreach tuple : [['myhostname', 'ENABLE_NSS_MYHOSTNAME'],
librt],
link_depends : sym,
install : true,
+ install_tag : 'nss',
install_dir : rootlibdir)
# We cannot use shared_module because it does not support version suffix.
# Unfortunately shared_library insists on creating the symlink…
meson.add_install_script('sh', '-c',
'rm $DESTDIR@0@/libnss_@1@.so'
- .format(rootlibdir, module))
+ .format(rootlibdir, module),
+ install_tag : 'nss'
+ )
if want_tests != 'false'
test('dlopen-nss_' + module,