summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLuca Boccassi <bluca@debian.org>2022-05-15 14:52:19 +0100
committerGitHub <noreply@github.com>2022-05-15 14:52:19 +0100
commit943fadde485d38c121270b75ce92b55b14e3176b (patch)
tree3747057ac6c7b7b21e77d0c0370fe09929357330 /meson.build
parent488b8acaeac450cce18f3ef3d081af697d481be9 (diff)
parent260c0a80ac6829b548653b0cff791c85e9f72a22 (diff)
downloadsystemd-943fadde485d38c121270b75ce92b55b14e3176b.tar.gz
Merge pull request #23378 from floppym/install-tags
Add install tags for nss modules and pkgconfig files
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e43dcf7d50..dfe1ff17b3 100644
--- a/meson.build
+++ b/meson.build
@@ -2140,13 +2140,16 @@ foreach tuple : [['myhostname', 'ENABLE_NSS_MYHOSTNAME'],
librt],
link_depends : sym,
install : true,
+ install_tag : 'nss',
install_dir : rootlibdir)
# We cannot use shared_module because it does not support version suffix.
# Unfortunately shared_library insists on creating the symlink…
meson.add_install_script('sh', '-c',
'rm $DESTDIR@0@/libnss_@1@.so'
- .format(rootlibdir, module))
+ .format(rootlibdir, module),
+ install_tag : 'nss'
+ )
if want_tests != 'false'
test('dlopen-nss_' + module,