summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-05-16 15:31:00 +0200
committerYu Watanabe <watanabe.yu+github@gmail.com>2021-05-19 10:24:43 +0900
commite0698c66f4569c91e3fdd54ca77449698ae38704 (patch)
tree9d6cd0c6e0850d275618a248a6d9f3675a9c5b81 /meson.build
parentbe21b60b8993aa75b35c40c15b23cd32972a2c1b (diff)
downloadsystemd-e0698c66f4569c91e3fdd54ca77449698ae38704.tar.gz
meson, mkosi: pull in jinja2 as required
In preparation for subsequent changes.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a8bbeacd85..5dc083f47f 100644
--- a/meson.build
+++ b/meson.build
@@ -655,6 +655,12 @@ endif
############################################################
+if run_command('python3', '-c', 'import jinja2').returncode() != 0
+ error('python3 jinja2 missing')
+endif
+
+############################################################
+
gperf = find_program('gperf')
gperf_test_format = '''