summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2018-06-19 11:26:11 +0300
committerHugo <hugovk@users.noreply.github.com>2018-06-19 11:26:11 +0300
commitffd38e498f3fb9d4ede38c4a255ff595355abcad (patch)
treefacc78e7de0a17d0551d24a34dd53fefd5925ffb /setup.py
parentc951033b33b9525e823d0a0f214c3defa9dd9327 (diff)
downloadsimplejson-ffd38e498f3fb9d4ede38c4a255ff595355abcad.tar.gz
Add python_requires to help pip
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6805b55..d1a44a6 100644
--- a/setup.py
+++ b/setup.py
@@ -18,6 +18,8 @@ DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python"
with open('README.rst', 'r') as f:
LONG_DESCRIPTION = f.read()
+PYTHON_REQUIRES = '>=2.5, !=3.0.*, !=3.1.*, !=3.2.*'
+
CLASSIFIERS = [
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
@@ -101,6 +103,7 @@ def run_setup(with_binary):
description=DESCRIPTION,
long_description=LONG_DESCRIPTION,
classifiers=CLASSIFIERS,
+ python_requires=PYTHON_REQUIRES,
author="Bob Ippolito",
author_email="bob@redivi.com",
url="https://github.com/simplejson/simplejson",