summaryrefslogtreecommitdiff
path: root/examples/renderer-plugins/vala/Makefile.am
diff options
context:
space:
mode:
authorMurray Cumming <murrayc@murrayc.com>2012-11-19 13:57:22 +0100
committerMurray Cumming <murrayc@murrayc.com>2012-11-19 13:57:22 +0100
commitf0c5513c706fd2c535070de45f44f383f1911e44 (patch)
treeaaf291945ea3c3a11a094c6b18eaf7d7510e5e10 /examples/renderer-plugins/vala/Makefile.am
parent89dfc1045a608484092bc1f1b5b5f6919a4ca8f1 (diff)
downloadrygel-f0c5513c706fd2c535070de45f44f383f1911e44.tar.gz
example renderer plugin: Rename this with a -vala prefix.
So that things are clearer when I add the C version, and so that there is no conflict caused by two plugins containing the same symbols.
Diffstat (limited to 'examples/renderer-plugins/vala/Makefile.am')
-rw-r--r--examples/renderer-plugins/vala/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/examples/renderer-plugins/vala/Makefile.am b/examples/renderer-plugins/vala/Makefile.am
index 27dcc103..33e829c4 100644
--- a/examples/renderer-plugins/vala/Makefile.am
+++ b/examples/renderer-plugins/vala/Makefile.am
@@ -1,20 +1,20 @@
include $(top_srcdir)/common.am
-plugin_LTLIBRARIES = librygel-example-renderer-plugin.la
+plugin_LTLIBRARIES = librygel-example-renderer-plugin-vala.la
-AM_CFLAGS += -DG_LOG_DOMAIN='"Example"'
+AM_CFLAGS += -DG_LOG_DOMAIN='"ExampleRendererPluginVala"'
-librygel_example_renderer_plugin_la_SOURCES = \
- example-renderer-plugin.vala \
- example-player.vala
+librygel_example_renderer_plugin_vala_la_SOURCES = \
+ example-renderer-plugin-vala.vala \
+ example-player-vala.vala
-librygel_example_renderer_plugin_la_VALAFLAGS = \
+librygel_example_renderer_plugin_vala_la_VALAFLAGS = \
--pkg gstreamer-0.10 \
$(RYGEL_COMMON_RENDERER_PLUGIN_VALAFLAGS)
-librygel_example_renderer_plugin_la_LIBADD = \
+librygel_example_renderer_plugin_vala_la_LIBADD = \
$(LIBGSTREAMER_LIBS) \
$(RYGEL_COMMON_RENDERER_LIBS)
-librygel_example_renderer_plugin_la_LDFLAGS = \
+librygel_example_renderer_plugin_vala_la_LDFLAGS = \
$(RYGEL_PLUGIN_LINKER_FLAGS)