summaryrefslogtreecommitdiff
path: root/tests/auto/websockets/qwebsocketserver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/websockets/qwebsocketserver/CMakeLists.txt')
-rw-r--r--tests/auto/websockets/qwebsocketserver/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/tests/auto/websockets/qwebsocketserver/CMakeLists.txt b/tests/auto/websockets/qwebsocketserver/CMakeLists.txt
new file mode 100644
index 0000000..7a5cdfa
--- /dev/null
+++ b/tests/auto/websockets/qwebsocketserver/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Generated from qwebsocketserver.pro.
+
+#####################################################################
+## tst_qwebsocketserver Test:
+#####################################################################
+
+add_qt_test(tst_qwebsocketserver
+ SOURCES
+ tst_qwebsocketserver.cpp
+ PUBLIC_LIBRARIES
+ Qt::WebSockets
+)
+
+# Resources:
+set_source_files_properties("../shared/localhost.cert"
+ PROPERTIES QT_RESOURCE_ALIAS "localhost.cert"
+)
+set_source_files_properties("../shared/localhost.key"
+ PROPERTIES QT_RESOURCE_ALIAS "localhost.key"
+)
+set(qwebsocketshared_resource_files
+ "localhost.cert"
+ "localhost.key"
+)
+
+add_qt_resource(tst_qwebsocketserver "qwebsocketshared"
+ PREFIX
+ "/"
+ BASE
+ "../shared"
+ FILES
+ ${qwebsocketshared_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:qwebsocketserver.pro:<TRUE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_qwebsocketserver CONDITION boot2qt
+ DEFINES
+ SHOULD_CHECK_SYSCALL_SUPPORT
+)