summaryrefslogtreecommitdiff
path: root/tests/auto/websockets/qwebsocketserver/CMakeLists.txt
diff options
context:
space:
mode:
authorMaurice Kalinowski <maurice.kalinowski@qt.io>2019-09-16 14:22:07 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-09-16 14:47:09 +0000
commita3c87a0e44bb67cc3f726dd915178f9f307480e8 (patch)
tree6b40f1f687dd6e25d71e41c37eed2b230524e83f /tests/auto/websockets/qwebsocketserver/CMakeLists.txt
parenta5b0495ac273bcc841298b52dae3ca9bb608edf7 (diff)
downloadqtwebsockets-a3c87a0e44bb67cc3f726dd915178f9f307480e8.tar.gz
Add initial-support for cmake
Task-number: QTBUG-78180 Change-Id: If6cf82c61d605332402feffca9bde2ea0dd6e313 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/websockets/qwebsocketserver/CMakeLists.txt')
-rw-r--r--tests/auto/websockets/qwebsocketserver/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/tests/auto/websockets/qwebsocketserver/CMakeLists.txt b/tests/auto/websockets/qwebsocketserver/CMakeLists.txt
new file mode 100644
index 0000000..7a5cdfa
--- /dev/null
+++ b/tests/auto/websockets/qwebsocketserver/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Generated from qwebsocketserver.pro.
+
+#####################################################################
+## tst_qwebsocketserver Test:
+#####################################################################
+
+add_qt_test(tst_qwebsocketserver
+ SOURCES
+ tst_qwebsocketserver.cpp
+ PUBLIC_LIBRARIES
+ Qt::WebSockets
+)
+
+# Resources:
+set_source_files_properties("../shared/localhost.cert"
+ PROPERTIES QT_RESOURCE_ALIAS "localhost.cert"
+)
+set_source_files_properties("../shared/localhost.key"
+ PROPERTIES QT_RESOURCE_ALIAS "localhost.key"
+)
+set(qwebsocketshared_resource_files
+ "localhost.cert"
+ "localhost.key"
+)
+
+add_qt_resource(tst_qwebsocketserver "qwebsocketshared"
+ PREFIX
+ "/"
+ BASE
+ "../shared"
+ FILES
+ ${qwebsocketshared_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:qwebsocketserver.pro:<TRUE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_qwebsocketserver CONDITION boot2qt
+ DEFINES
+ SHOULD_CHECK_SYSCALL_SUPPORT
+)