summaryrefslogtreecommitdiff
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 4badc3d426..13e721851e 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -399,3 +399,15 @@ endif()
target_include_directories(mapbox-gl-native SYSTEM INTERFACE
${GIT_ROOT}/include
)
+
+add_executable(app
+ ${GIT_ROOT}/core/app.cpp
+)
+
+target_link_libraries(app PRIVATE
+ mapbox-gl-native
+)
+
+target_include_directories(app PRIVATE
+ ${GIT_ROOT}/platform/default
+)