summaryrefslogtreecommitdiff
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Marcos P. Santos <tmpsantos@gmail.com>2018-10-25 03:10:58 +0300
committerThiago Marcos P. Santos <tmpsantos@gmail.com>2018-10-25 03:15:43 +0300
commitcdbe554f13ad3f9893132ce9c9c7f3e22e5afcc9 (patch)
tree6552754aa33b9b7b29f9775252f3c1da374ec224 /core/CMakeLists.txt
parent1b703ed634dc82610ce58c63fbf5a37dc40d9c86 (diff)
downloadqtlocation-mapboxgl-upstream/tmpsantos-core_build.tar.gz
[build] Add test appupstream/tmpsantos-core_build
The app is need to fix linker issues.
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 4badc3d426..13e721851e 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -399,3 +399,15 @@ endif()
target_include_directories(mapbox-gl-native SYSTEM INTERFACE
${GIT_ROOT}/include
)
+
+add_executable(app
+ ${GIT_ROOT}/core/app.cpp
+)
+
+target_link_libraries(app PRIVATE
+ mapbox-gl-native
+)
+
+target_include_directories(app PRIVATE
+ ${GIT_ROOT}/platform/default
+)