summaryrefslogtreecommitdiff
path: root/tests/tools/qml-ast2dot/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tools/qml-ast2dot/CMakeLists.txt')
-rw-r--r--tests/tools/qml-ast2dot/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/tools/qml-ast2dot/CMakeLists.txt b/tests/tools/qml-ast2dot/CMakeLists.txt
new file mode 100644
index 0000000000..5e4a852243
--- /dev/null
+++ b/tests/tools/qml-ast2dot/CMakeLists.txt
@@ -0,0 +1,13 @@
+add_qtc_executable(qml_ast2dot
+ BUILD_DEFAULT OFF
+ DEPENDS Qt5::Core Qt5::Gui QmlJS
+ SOURCES main.cpp
+)
+
+extend_qtc_executable(qml_ast2dot
+ PROPERTIES
+ OUTPUT_NAME "qml-ast2dot"
+ LIBRARY_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}"
+ ARCHIVE_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}"
+ RUNTIME_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}"
+)