summaryrefslogtreecommitdiff
path: root/src/plugins/qmakeprojectmanager/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@gmail.com>2019-05-12 22:20:56 +0200
committerCristian Adam <cristian.adam@gmail.com>2019-05-17 13:33:28 +0000
commitd855b84c5df923394ace3bb91dab379f7e0daa34 (patch)
treee184ccdf5724151465a1653f9fc308af43293de8 /src/plugins/qmakeprojectmanager/CMakeLists.txt
parentf872a95fddd2690bb6953a17e48935c1b12d83d9 (diff)
downloadqt-creator-d855b84c5df923394ace3bb91dab379f7e0daa34.tar.gz
Qt Creator CMake port
Based on Tobias Hunger's work from a few months ago. The CMake configuration needs libclang and Qt paths specified as CMAKE_PREFIX_PATH. Auto tests are run with "ctest". At the moment the pass rate is 87%. Change-Id: Iba98e39bf22077d52706dce6c85986be67a6eab0 Reviewed-by: Alessandro Portale <alessandro.portale@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io> Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'src/plugins/qmakeprojectmanager/CMakeLists.txt')
-rw-r--r--src/plugins/qmakeprojectmanager/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/src/plugins/qmakeprojectmanager/CMakeLists.txt b/src/plugins/qmakeprojectmanager/CMakeLists.txt
new file mode 100644
index 0000000000..5cd7b6cc19
--- /dev/null
+++ b/src/plugins/qmakeprojectmanager/CMakeLists.txt
@@ -0,0 +1,53 @@
+add_qtc_plugin(QmakeProjectManager
+ DEPENDS qmljs
+ PLUGIN_DEPENDS Core CppTools QtSupport ResourceEditor TextEditor
+ PLUGIN_RECOMMENDS Designer
+ SOURCES
+ addlibrarywizard.cpp addlibrarywizard.h
+ applicationlauncher.h
+ customwidgetwizard/classdefinition.cpp customwidgetwizard/classdefinition.h customwidgetwizard/classdefinition.ui
+ customwidgetwizard/classlist.cpp customwidgetwizard/classlist.h
+ customwidgetwizard/customwidgetpluginwizardpage.cpp customwidgetwizard/customwidgetpluginwizardpage.h customwidgetwizard/customwidgetpluginwizardpage.ui
+ customwidgetwizard/customwidgetwidgetswizardpage.cpp customwidgetwizard/customwidgetwidgetswizardpage.h customwidgetwizard/customwidgetwidgetswizardpage.ui
+ customwidgetwizard/customwidgetwizard.cpp customwidgetwizard/customwidgetwizard.h
+ customwidgetwizard/customwidgetwizarddialog.cpp customwidgetwizard/customwidgetwizarddialog.h
+ customwidgetwizard/filenamingparameters.h
+ customwidgetwizard/plugingenerator.cpp customwidgetwizard/plugingenerator.h
+ customwidgetwizard/pluginoptions.h
+ desktopqmakerunconfiguration.cpp desktopqmakerunconfiguration.h
+ externaleditors.cpp externaleditors.h
+ librarydetailscontroller.cpp librarydetailscontroller.h
+ librarydetailswidget.ui
+ makefileparse.cpp makefileparse.h
+ profilecompletionassist.cpp profilecompletionassist.h
+ profileeditor.cpp profileeditor.h
+ profilehighlighter.cpp profilehighlighter.h
+ profilehoverhandler.cpp profilehoverhandler.h
+ qmakebuildconfiguration.cpp qmakebuildconfiguration.h
+ qmakebuildinfo.h
+ qmakekitinformation.cpp qmakekitinformation.h
+ qmakemakestep.cpp qmakemakestep.h
+ qmakenodes.cpp qmakenodes.h
+ qmakenodetreebuilder.cpp qmakenodetreebuilder.h
+ qmakeparser.cpp qmakeparser.h
+ qmakeparsernodes.cpp qmakeparsernodes.h
+ qmakeproject.cpp qmakeproject.h
+ qmakeprojectconfigwidget.cpp qmakeprojectconfigwidget.h
+ qmakeprojectimporter.cpp qmakeprojectimporter.h
+ qmakeprojectmanager.cpp qmakeprojectmanager.h
+ qmakeprojectmanager.qrc
+ qmakeprojectmanager_global.h
+ qmakeprojectmanagerconstants.h
+ qmakeprojectmanagerplugin.cpp qmakeprojectmanagerplugin.h
+ qmakesettings.cpp qmakesettings.h
+ qmakestep.cpp qmakestep.h qmakestep.ui
+ qtmodulesinfo.cpp qtmodulesinfo.h
+ wizards/filespage.cpp wizards/filespage.h
+ wizards/modulespage.cpp wizards/modulespage.h
+ wizards/qtprojectparameters.cpp wizards/qtprojectparameters.h
+ wizards/qtwizard.cpp wizards/qtwizard.h
+ wizards/simpleprojectwizard.cpp wizards/simpleprojectwizard.h
+ wizards/subdirsprojectwizard.cpp wizards/subdirsprojectwizard.h
+ wizards/subdirsprojectwizarddialog.cpp wizards/subdirsprojectwizarddialog.h
+ wizards/wizards.qrc
+)