summaryrefslogtreecommitdiff
path: root/src/plugins/perforce/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@gmail.com>2019-05-12 22:20:56 +0200
committerCristian Adam <cristian.adam@gmail.com>2019-05-17 13:33:28 +0000
commitd855b84c5df923394ace3bb91dab379f7e0daa34 (patch)
treee184ccdf5724151465a1653f9fc308af43293de8 /src/plugins/perforce/CMakeLists.txt
parentf872a95fddd2690bb6953a17e48935c1b12d83d9 (diff)
downloadqt-creator-d855b84c5df923394ace3bb91dab379f7e0daa34.tar.gz
Qt Creator CMake port
Based on Tobias Hunger's work from a few months ago. The CMake configuration needs libclang and Qt paths specified as CMAKE_PREFIX_PATH. Auto tests are run with "ctest". At the moment the pass rate is 87%. Change-Id: Iba98e39bf22077d52706dce6c85986be67a6eab0 Reviewed-by: Alessandro Portale <alessandro.portale@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io> Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'src/plugins/perforce/CMakeLists.txt')
-rw-r--r--src/plugins/perforce/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/plugins/perforce/CMakeLists.txt b/src/plugins/perforce/CMakeLists.txt
new file mode 100644
index 0000000000..9a3dd9e59c
--- /dev/null
+++ b/src/plugins/perforce/CMakeLists.txt
@@ -0,0 +1,17 @@
+add_qtc_plugin(Perforce
+ PLUGIN_DEPENDS Core TextEditor VcsBase
+ SOURCES
+ annotationhighlighter.cpp annotationhighlighter.h
+ changenumberdialog.cpp changenumberdialog.h changenumberdialog.ui
+ pendingchangesdialog.cpp pendingchangesdialog.h pendingchangesdialog.ui
+ perforcechecker.cpp perforcechecker.h
+ perforceeditor.cpp perforceeditor.h
+ perforceplugin.cpp perforceplugin.h
+ perforcesettings.cpp perforcesettings.h
+ perforcesubmiteditor.cpp perforcesubmiteditor.h
+ perforcesubmiteditorwidget.cpp perforcesubmiteditorwidget.h
+ perforceversioncontrol.cpp perforceversioncontrol.h
+ promptdialog.ui
+ settingspage.cpp settingspage.h settingspage.ui
+ submitpanel.ui
+)