summaryrefslogtreecommitdiff
path: root/src/plugins/helloworld/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-05-23 15:13:06 +0200
committerTobias Hunger <tobias.hunger@qt.io>2019-09-17 12:37:14 +0000
commitc3f31b6332e4b96e2089b0d6a15d617cc2cae49f (patch)
tree833bd21bd86cc260eefadd5fb1e305413140dff2 /src/plugins/helloworld/CMakeLists.txt
parentdac42e9e28be1d9dade5acedee82271fba794495 (diff)
downloadqt-creator-c3f31b6332e4b96e2089b0d6a15d617cc2cae49f.tar.gz
CMake: Handle translations
(Optionally) re-generate .ts files from CMake by running lupdate and run lrelease to generate .qm files. Changes to qmake: * src/libs/3rdparty/syntax-highlighting/src/cli/kate-syntax-highlighter.cpp is no longer translated: It's a command line tool that is not used by creator * src/libs/aggregation/examples/text/main.cpp is no longer included in ts files * src/libs/qt-breakpad/qtcrashhandler/* is no longer included in ts files: It is not built right now Change-Id: Iec018da86a111a68ec983a880cef2961b48ccdf9 Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'src/plugins/helloworld/CMakeLists.txt')
-rw-r--r--src/plugins/helloworld/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/helloworld/CMakeLists.txt b/src/plugins/helloworld/CMakeLists.txt
index 6b9c5df88d..e14fbba2c8 100644
--- a/src/plugins/helloworld/CMakeLists.txt
+++ b/src/plugins/helloworld/CMakeLists.txt
@@ -1,4 +1,5 @@
add_qtc_plugin(HelloWorld
+ SKIP_TRANSLATION
PLUGIN_DEPENDS Core
SOURCES
helloworldplugin.cpp helloworldplugin.h