summaryrefslogtreecommitdiff
path: root/dist/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2022-06-21 10:59:40 +0200
committerEike Ziller <eike.ziller@qt.io>2022-06-29 12:04:37 +0000
commitb364cfde2375b2fa56b97e42346affecd2030080 (patch)
tree9e0431e8e2d44df2644fb98a51b10c6e2bd6ac48 /dist/CMakeLists.txt
parent733904929076be0e874e2c2ec1fb8ff2867342b5 (diff)
downloadqt-creator-b364cfde2375b2fa56b97e42346affecd2030080.tar.gz
Install and ship change logs
And add a menu entry Help > Change Log... (macOS: Qt Creator > Change Log...) for looking at them. Change-Id: If444b3ff2465290b9beb4ccbb8d0ddf32a636db4 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: hjk <hjk@qt.io>
Diffstat (limited to 'dist/CMakeLists.txt')
-rw-r--r--dist/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/dist/CMakeLists.txt b/dist/CMakeLists.txt
new file mode 100644
index 0000000000..14c8d31a1d
--- /dev/null
+++ b/dist/CMakeLists.txt
@@ -0,0 +1,11 @@
+# copy resource directories during build
+qtc_copy_to_builddir(copy_changelog_to_builddir
+ DIRECTORIES changelog
+ DESTINATION "${IDE_DATA_PATH}"
+ CREATE_SUBDIRS
+)
+
+install(
+ DIRECTORY changelog
+ DESTINATION ${IDE_DATA_PATH}
+)